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Scisense PV Technical Note
How to Analyze PV Loop Data (Admittance) 
in LabScribe2 Software
The following document outlines suggested steps for analyzing PV loop data in LabScribe2 software when 
used in conjunction with the ADV500 PV system. Every experiment is different and may require different 
settings or the use of different software features. Please contact iWorx directly for additional information 
about all the available features or any software functionality issues.

For the purpose of this exercise a sample file recorded from a healthy swine using the ADV500 PV system 
will be used. Only RAW data were recorded at the time of the experiment, therefore, this example does 
not show hemodynamic measurements as calculated channels over time. Remember, that these channels 
can be created during analysis if required to show trends over the course of the experiment.

Basic Labscribe2 Functions for PV Loops

Full screen view of the swine Left Ventricle PV data collected using the 
ADV500 PV System. There are three channels of raw data: Pressure (mmHg), 
Phase (degree°) and Magnitude (µS or mS) and one calculated channel: 
Volume (mL). The X-Y view of Pressure-Volume Loops are on the right.
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The Main Window Toolbar features icons for quick access to key features that help with data manipulation and analysis.

Each channel has its own control located in the channel bar immediately above channel’s data. The channel bar allows for 
zooming in and out, autoscaling the amplitude of recorded data, adding function to the channel, changing its title, etc.

The channel menu triangle 
contains functions specific 
to channel. The channel 
menu can also be accessed 
by right-clicking anywhere 
in the channel.

CHANNEL MENU
Important channel functions for data analysis include: 

• Invert: Inverts the trace

• Title: Opens a dialog allowing changing the title of the channel 

• Color: Opens color palette allowing to change the color of the channel trace

• Units: Displays unit conversion option

• Scale: Displays the option to control the vertical axis of the channel
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USING & MOVING CURSORS

The value of the single cursor or the difference between the two cursors is displayed in the Clock Area.

During data analysis, cursors can be moved by placing the mouse over the cursor clicking and dragging it to the 
right or left. The cursor on the left is always cursor number 1, while the cursor on the right is number 2. If you 
move cursor number 2 to the left passed cursor 1 it becomes the new cursor number 1. 

In the two cursor mode, the cursors can be locked at a set interval to allow for viewing a constant amount of 
data. To lock separation distance, position the two cursors at the desired separation and choose “Tools > Lock 
Cursor Separation” To unlock the distance click “Lock Cursor Separation” a second time.

MARKING A CHANNEL
Click on Single Cursor Icon in the Toolbar. Position the cursor on the file where mark should be positioned. 
Then type text associated with this mark into the Marks area and hit enter. To later edit or delete the mark 
access the mark dialog from View menu or by clicking on the Marks Icon on the Toolbar. Marks are valuable for 
keeping track of key events but can also be used to make note of system variables or experimental conditions.

In addition to marking static data, you can also make Marks during live data collection. To accomplish this, 
simply type your intended information in the Mark area (as described above) and hit Enter. A mark will be 
time-stamped at the moment that you hit Enter allowing for easy data review following protocol completion.

Addition of Computed Function Channel
The addition of computed functional channels can aid in analysis by providing important 
information e.g. adding the Derivative from the raw Pressure channel (dP/dt channel). 
Other useful computed functional channels include Integral, Channel Math, Filter and 
Smoothing. To add a functional channel to the current channel click on [add function].

DERIVATIVES
The Derivative function calculates the derivative (slope) around each point in the raw 
data, and then displays it on the calculated channel. On the new derivative channel, the 
units are changed to the units of the raw data channel/second. Higher order derivatives 
can be calculated by applying a Derivative function to a Derivative channel.

INTEGRALS
An integral is the area under a curve. In pressure-volume data analysis you mostly utilize 
the integral calculating channel for performing pressure wave analysis or calculating the 
integral of a flow waveform from a Transonic Flowprobe to obtain 
stroke volume (SV). There are four types of integrals; the two most 
common ones are Standard and Absolute.

Standard: Includes all data points in the calculation.

Absolute: The Absolute Value of the Integral, as the name implies, 
makes all values of the integral positive and plots the running total. 
Data points with values above zero make the integral larger, those with 
values less than zero make the integral smaller. To successfully complete 
the calculation of the integral, the location of the zero-line or baseline 
needs to be established. 

Setting the baseline of the raw data channel to zero is important 
because this function defines the difference between positive and 

Add function menu

Setting the baseline for use with integral
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negative areas of the recording. If the baseline of the raw data 
record is in the positive range of amplitudes, then the integral will 
have a positive slope, even though no signal is present. Conversely, 
if the baseline of the raw data is in the negative range, the 
integral will have a negative slope.

CHANNEL MATH
The Channel Math function applies a user-defined function to 
up to four data channels and displays the output in a computed 
channel. Each of four variables (A, B, C and D) can be associated 
with a user-selected data channel.

FILTERING
A digital filter can be applied to any channel in real time or to previously recorded data. LabScribe2 uses a 
FIR (Finite Impulse Response) filter. There are various windowing functions that can be used for setting up an 
FIR filter. The Hamming window (default) is appropriate for most applications. In addition to the Hamming 
function, LabScribe2 also provides Rectangular, Bartlett, Hanning, Blackman and Blackman-Harris windowing 
functions.

For the data analysis of pressure-volume data it is recommended to use a Smoothing function rather than data 
filtering to prevent loss of the pressure high-fidelity signal. It has been established by researchers that in order 
to accurately recreate a blood pressure waveform, the sensing system must be able to accurately measure up to 
the 20th harmonic of the observed waveform (1). Furthermore, based on work of Dr. Grossman discussing the 
accuracy of capturing and reporting the pressure signal: “If components of a particular frequency range are 
either suppressed or exaggerated by the transducer system, the resulting signals will be greatly distorted”(2).

If you choose to filter your data. On the 
channel of interest, click on [add function] 
then select “Periodic > Frequency”. A 
Frequency channel in Hz will be created. 
Determine the highest frequency and then 
multiply by 20 to get the 20th harmonic, 
that value will become the “High Cutoff” 
value for the FIR filter. To apply the filter 
click on [add function] select “Filter > FIR 
Filter”.

SMOOTHING
Smoothing is used to remove noise that is 
uniform across all frequencies. LabScribe2 
has the ability to smooth the data in 
order to reveal significant features of your 
data. There are two different algorithms 
to smooth the data; the Moving Average 
function does wide smoothing, while the 
Savitzky-Golay seeks to preserve shapes of 
peaks. 

How to Analyze PV Loop Data in LabScribe Cont.

The first channel is raw pressure data. The second channel is unmodified 
volume data. The third channel is volume data smoothed by Savitsky-
Golay second order polynomial with 7 points of data on each side. The 
fourth channel is volume data smoothed by Savitsky-Golay second order 
polynomial with 21 points of data on each side. The red PV loops are 
created from the unsmoothed data while the green loops are from the 21 
points smoothed data.

Channel Math allows for custom functions based 
on up to four channels
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The Savitzky-Golay method essentially performs 
a local polynomial regression to determine the 
smoothed value for each data point. For analysis of 
pressure-volume this method is superior to Moving 
Average because it tends to preserve features of the 
data such as peak height and width, which are often 
diminished by adjacent averaging.

When using the Savitsky-Golay smoothing function 
it is best to start with a smaller number of points on 
each side and then increase the number of points later 
after assessing how the smoothing impacts the data 
to prevent data distortion from over smoothing.

Specific PV Loop Functions
Analysis specific to PV loops is started by choosing the 
“Advanced > PV Loops”, then choosing one of two options: 
Online Calculations and Offline Calculations. 

ONLINE CALCULATIONS
Choose Online Calculations from the PV Loops submenu. 
Click on the triangle in the upper left corner to open the 
PV Loop Online Calculations Setup window. Select the appropriate 
Pressure Channel and Volume Channel for the loops. Set Average 
Cycles to something other than zero, otherwise the loop will never 
refresh. Set the threshold for detecting cycles to “Use percentage 
of Max and Min scaling” and adjust the threshold bars to include 
acceptable pressures. Keep in mind the impact of IVC occlusion 
(reduced pressure) when setting the threshold to ensure all cycles 
are included.

OFFLINE CALCULATIONS
Choose Offline Calculations from the PV Loops submenu to open 
the PV Loop Calculations Dialog. The panels of this dialog can be 
re-sized by moving the mouse cursor over the boundaries until a 
double headed arrow appears, and dragging the boundaries to re-
size the panels.

LabScribe2 can calculate virtually every PV Loop derived parameter 
(Steady-state or post-occlusion condition) of cardiac function. XY 
graphs display relationships among the parameters. All calculations 
can be exported or copied to MS Excel or other spreadsheets for 
further analysis. The graphs can all be copied as images to include 
in presentations or manuscripts. When the Offline calculations is 
open, 4 tab panels become available: Channels, Setting, Results and 
Display.

Select PV Loop Online or Offline Calculations

PV Loop Online Calculations Setup Menu

Open the PV Loop Online Calculations Setup Menu by 
clicking the triangle in the corner.



CHANNELS
The Channels tab enables the selection 
of the channels that will be displayed in 
the XY graph. To create PV loops select 
the Pressure channel and Volume channel 
along with the appropriate units. Once 
the Pressure and Volume channels are 
designated, the PV Loops will be displayed 
in the XY graph area for all the cycles in 
the selection. Define the region of interest 
by adjusting the two cursors in the 
channel display area at the top of the PV 
Loops Calculations Dialog. This will select 
the amount of PV loops (in this case 12). 

If you wish to add more PV loop cycles 
than the amount availabe in the top 
channel, you have to go back to the Main 
Window and use the double display time 
icon to increase the amount of PV loop 
data. 

The highlighted cycle in the Cycles Selected window 
is shown in red, while all other selected cycles are 
displayed in green. Parameters related to each cycle 
are shown in the table at the bottom. Cycles can be 
deselected (or selected) by clicking on the check box to 
the left of the cycle number. This allows for identifying 
individual loops (individual cycles) for inclusion or 
exclusion from the analysis.

SETTINGS
• When recording using ECG channel, check whether 

you wish to use an ECG for the detection of end 
diastole (ED). 

• For OCCLUSION condition, please choose whether a 
linear or an exponential fit should be applied to the 
End-Systolic Pressure-Volume Relationship (ESPVR) 
data, using the ESPVR Fit Type drop-down box. In 
rodents, usually linear; in larger animals, compare 
both linear and exp. fit. Please review appropriate 
literature in order to select ESPVR fit type. 

• For OCCLUSION condition, leave EDPVR fit type as 
exponential.  This relationship is based on literature 
citation (Am J Physiol Heart Circ Physiol. 2005 
Aug;289(2):H501-12). If pressures fall below zero, a 
message will appear requesting that the data be 
offset in the positive direction in order to perform the 
calculation.
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Channels tab for selecting the data channels used to create the PV loops. 
Use the Cycles Selected menu to include or exclude specific loops.

Settings tab for selecting the methods for calculating key 
parameters
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• Choose the value in each cycle that should 
be used to compute end-systole (ES), and 
how far to offset ES from the specified 
value. 

• For OCCLUSION condition, by default 
the maximum Pressure to Volume ratio 
is used to identify ES. When calculating 
PRSW (Preload Recruitable Stroke Work), 
as it is calculated by using detection of 
EDV rather than V max. If the isovolumic 
contraction period of PV loop is deformed 
or in case of RV-PV loops select Vmax to 
re-analyse. 

• Enter the stop value to be included in the 
best fit line used for the determination 
of isovolumic relaxation time (IVRT) Tau. 
Tau is the isovolumic time constant and is 
calculated using the line from dPmin to this 
user-defined point. Leave value 5 mmHg 
as user defined point for the beginning of 
analysis. For more info about Tau please 
see Tech Note: “Understanding Lusitropy: 
Passive Diastolic Properties and Active 
Myocardial Relaxation.”

• For Cycle detection threshold sensitivity 
and Ventricular Wall Volume leave the 
number of cycles that should be used to 
determine the Cycle Detection Threshold 
Sensitivity with default values.

• In case you wish to use PV loop(s) 
superimposed on each other for 
comparison please select Save Occlusion 
data tab. Select File name and iWorx 
Occlusion file (.iwxocc) format. This 
superimposed data can also be used to 
compare PV loops during Steady state 
conditions or to compare multiple vs single loops.

RESULTS
The equations defining ESPVR, EDPVR, PRSW, Max dP vs. EDV, PVA vs. EDV, and PVA vs. ESP are displayed, as 
is Emax. By clicking on the Algorithm button, parameters are detailed including the description/or literature 
citation. Parameters that are displayed can be easily copied using the copy button. When you select copy, 
parameters are copied for both occlusion and steady state, although only occlusion values are displayed. When 
copied into MS Excel or other program they can be easily post-processed.

Click [Table Options] to adjust which parameters are displayed

Results tab for view the equations used for calculating key parameters
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Transonic Systems Inc. is a global manufacturer of innovative biomedical measurement 
equipment. Founded in 1983, Transonic sells “gold standard” transit-time ultrasound 
flowmeters and monitors for surgical, hemodialysis, pediatric critical care, perfusion, 
interventional radiology and research applications. In addition, Transonic provides 
pressure and pressure volume systems, laser Doppler flowmeters and telemetry systems.

AMERICAS
Transonic Systems Inc.
34 Dutch Mill Rd
Ithaca, NY 14850
U.S.A.
Tel: +1 607-257-5300
Fax: +1 607-257-7256
support@transonic.com

EUROPE
Transonic Europe B.V.
Business Park Stein 205
6181 MB Elsloo
The Netherlands
Tel: +31 43-407-7200
Fax: +31 43-407-7201
europe@transonic.com

ASIA/PACIFIC
Transonic Asia Inc.
6F-3 No 5 Hangsiang Rd
Dayuan, Taoyuan County
33747 Taiwan, R.O.C.
Tel: +886 3399-5806
Fax: +886 3399-5805
support@transonicasia.com

JAPAN
Transonic Japan Inc.
KS Bldg 201, 735-4 Kita-Akitsu
Tokorozawa Saitama
359-0038 Japan
Tel: +81 04-2946-8541
Fax: +81 04-2946-8542
info@transonic.jp

www.transonic.com
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DISPLAY
Clicking on a graph color allows for selecting a basic color 
or creating custom color for each type of selection. When it 
is necessary to hide a selection, as in case of PVR lines in for 
description of steady state PV loops, the color can be set to 
white.

Other display parameters that will be shown on PV loop 
graph include ES location, ED location, ESPVR, EDPVR, 
Ees vs. Ea, Tau start, Tau stop, and Average loop. When 
selected, parameters will appear on the PV loop graph.
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Display tab for selecting the parameters 
visible on the graph and their colors.


